Specific Bank Partner: Core Connectivity Bangor Savings Bank

Incident Report for Treasury Prime

Resolved

We are no longer seeing connectivity issues here.
Posted Dec 01, 2025 - 18:17 UTC

Monitoring

Successful connectivity and processing is now being seen within that connection. Treasury Prime is monitoring performance.
Posted Dec 01, 2025 - 18:05 UTC

Investigating

Treasury Prime is investigating errors in connecting to the core of one of our bank partners, Bangor Savings Bank. Teams are engaged in troubleshooting. This can impact on core balance reporting, book transfers, and may impact payment processing..
Posted Dec 01, 2025 - 17:50 UTC
This incident affected: Bank Console.