Duplicated Incoming ACH postings
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 21:43 UTC
Monitoring
We have reversed all the duplicate postings.
Posted Jan 24, 2024 - 20:29 UTC
Identified
We're investigating an issue where we are seeing duplicated incoming ACH postings.
Posted Jan 24, 2024 - 19:12 UTC