Incoming ACHs delayed at Piermont Bank
Incident Report for Treasury Prime
Resolved
We have resolved the issue and all the files have been processed.
Posted Apr 22, 2024 - 20:58 UTC
Identified
We are investigating an issue that is causing incoming ACHs to be delayed at Piermont Bank. We will post updates as we have them.
Posted Apr 22, 2024 - 16:47 UTC