Card and Transaction Issues - Outage
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 00:07 UTC
Monitoring
Our partner has resolved the issue and we’re monitoring the results
Posted Jul 15, 2024 - 23:08 UTC
Investigating
We're experiencing an outage with our card and transaction partner which could cause some errors with card updating / creation and transaction authorizations. We will update as we have more information.
Posted Jul 15, 2024 - 22:46 UTC