Specific Bank Partner: File connection impacting inbound payments at Piermont Bank

Incident Report for Treasury Prime

Resolved

Incoming wires and ACH items have been processed, and Treasury Prime is not experiencing any additional interruptions to the data flow.
Posted Mar 30, 2026 - 19:25 UTC

Update

Treasury Prime observed a successful connection at 2:30 PM ET and data has begun flowing for both incoming ACH and incoming wire processing. We continue to monitor the process.
Posted Mar 30, 2026 - 18:53 UTC

Update

Team continue to work on resolving the issue; in the interim, the teams are working to manually process outstanding files. Updates will be provided as that process completes.
Posted Mar 30, 2026 - 17:20 UTC

Update

The file connection between Treasury Prime and Piermont Bank for incoming ACH and wire payment has not been reestablished. Both teams are engaged in resolving the issue.
Posted Mar 30, 2026 - 15:13 UTC

Investigating

Treasury Prime is currently investigating a file transfer issue between ourselves and Piermont Bank. This is currently delaying the posting of incoming ACH items and incoming wires. We will provide updates as we work to resolve the issue.
Posted Mar 30, 2026 - 13:18 UTC