Microsoft / Crowdstrike Impact
Incident Report for Treasury Prime
Resolved
All known impacts have been reported to us as closed, and no additional issues were identified.
Posted Jul 20, 2024 - 00:28 UTC
Investigating
Treasury Prime is aware of the Microsoft / Crowdstrike issue impacting many systems globally. While we are not seeing any direct impacts to our platform, our partners may be experiencing delays or other impacts. For any specific process or delay questions, please reach out to our Technical Support team.
Posted Jul 19, 2024 - 14:05 UTC