API Latency

Incident Report for Treasury Prime

Resolved

Platform performance is in expected ranges at this time.
Posted Dec 12, 2025 - 20:29 UTC

Monitoring

A change was deployed and we are seeing response times back to baseline at this time. The team will continue to monitor performance.
Posted Dec 12, 2025 - 20:01 UTC

Update

Treasury Prime has seen the issue escalate and we are taking additional steps to mitigate the latency.
Posted Dec 12, 2025 - 19:17 UTC

Update

Treasury Prime is preparing a change which is expected to reduce this latency. Overall monitoring continues.
Posted Dec 12, 2025 - 17:58 UTC

Investigating

Treasury Prime is currently monitoring latency in API responses, with responses averaging 2 seconds. We are not seeing failures at this time. Teams are engaged in reviewing platform performance.
Posted Dec 12, 2025 - 16:00 UTC
This incident affected: API.