Data Processing Delays
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted Dec 22, 2022 - 15:35 UTC
Update
Data processing is catching up. We believe the issue has been resolved.
Posted Dec 22, 2022 - 15:34 UTC
Investigating
Our data processing is experiencing delays. We are investigating.
Posted Dec 22, 2022 - 15:06 UTC
This incident affected: API.