Specific Bank Issue: First Bank Core

Incident Report for Treasury Prime

Resolved

Communication with the First Bank core is operating as expected.
Posted Aug 31, 2025 - 00:25 UTC

Monitoring

Treasury Prime is seeing successful core connections with First Bank. We are monitoring,.
Posted Aug 31, 2025 - 00:16 UTC

Investigating

Treasury Primeis seeing errors when attempting to retrieve information from the First Bank core. This is impacting balance calls and other tranasctions that require core interaction. We are investigating.
Posted Aug 30, 2025 - 23:35 UTC
This incident affected: API.