Our partners are reporting recovery across their platforms, and we are not seeing any impacts in our own processes overnight. For any additional questions or issues, please reach out to help@treasuryprime.com
Posted Oct 21, 2025 - 13:45 UTC
Monitoring
Treasury Prime has seen a reduction in latency and timeouts as a result of our change, and we have seen a drop off in timeouts at our partners. Card settlement data remains in progress between Treasury Prime and Marqeta but is expected to be complete by tomorrow. We will continue to monitor platform performance and impacts.
Posted Oct 20, 2025 - 20:52 UTC
Update
Treasury Prime saw an increase in database latency and timeouts as our partners increased calls to us as they worked on recovery. This did cause some card authorizations to inaccurately decline as insufficient. We deployed a change to mitigate this 30 minutes ago and are continuing to monitor performance.
Posted Oct 20, 2025 - 18:56 UTC
Update
Treasury Prime is seeing intermittent API failures as a result of the AWS East incident. We continue to monitor internal performance and work with our partners Marqeta as well as Alloy to address current performance.
Posted Oct 20, 2025 - 16:39 UTC
Identified
Treasury Prime has seen an increase in timeout errors related to creating new cards or updating existing cards. Card transaction processing appears to be executing. We will work with out partner to address the increase of timeouts and determine what mitigation can be done.
Posted Oct 20, 2025 - 15:16 UTC
Monitoring
Treasury Prime is aware of the reported issue impacting AWS East. While Treasury Prime is not seeing any direct impacts our card processing partner has notified us that they are monitoring situation as some of their webhook messaging may be impacted. Treasury Prime will continue to monitor and take steps to mitigate impact if needed.