Production and Sandbox reduced service level
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted May 02, 2021 - 06:09 UTC
Monitoring
Connection appears back and we are monitoring.
Posted May 02, 2021 - 05:54 UTC
Investigating
Experiencing degraded performance due to bank system connectivity. We are investigating.
Posted May 02, 2021 - 05:43 UTC
This incident affected: API.