Service Specific: Remote Deposit Capture Processing Impacted

Incident Report for Treasury Prime

Resolved

Our Remote Deposit Capture partner has confirmed restored functionality and we are seeing that production function as expected.
Posted Sep 22, 2025 - 13:07 UTC

Update

Our Remote Deposit Capture partner has restored connectivity. We will continue to monitor functionality through the next processing cycle on Monday, September 22nd.
Posted Sep 20, 2025 - 11:08 UTC

Monitoring

Our Remote Deposit Capture partner continues to work on restoring service. Upon restoration, Treasury Prime services will also regain functionality. The next update will be published on Saturday, September 20th by 8 am ET.
Posted Sep 20, 2025 - 02:02 UTC

Identified

Our Remote Deposit Capture vendor has identified the issue impacting connectivity and are working to reestablish service.
Posted Sep 19, 2025 - 22:21 UTC

Update

Our Remote Deposit Capture vendor continue to work on resolving the the connectivity issues, but the issue remains ongoing at this time.
Posted Sep 19, 2025 - 21:56 UTC

Investigating

We have been notified by our Remote Deposit Capture partner of connectivity issues that are impacting the processing of RDC items. We are seeing those impacts in our environment and checks are ending in an error status. Our partner is working to resolve the issue and we will provides updates as available.
Posted Sep 19, 2025 - 19:05 UTC
This incident affected: API.