Specific Bank Partner: Connectivity Issue with Piermont Bank

Incident Report for Treasury Prime

Resolved

We are seeing transaction and payment activity occuring as expected. For details on any specific payment, please reach out to help@treasuryprime.com.
Posted Oct 02, 2025 - 16:51 UTC

Monitoring

We have seen improvements in response times and reduced errors. We are monitoring performance and continuing to engage with our partner bank. Payments that are in an error status will not be automatically retried, and the relevant payment will need to be resent to the API. If there are any questions on a particular payment, please reach out to help@treasuryprime.com
Posted Oct 02, 2025 - 14:46 UTC

Investigating

Treasury Prime is seeing a significant amount of failures in our communication with the Piermont Bank core. This is causing delays in book transfer processing, which is also impacting wire and ach payments. We are investigating on our side and have engaged our partner bank.
Posted Oct 02, 2025 - 13:31 UTC
This incident affected: API.