Payments may be delayed in Processing
Incident Report for Treasury Prime
Resolved
This Incident has been resolved
Posted Mar 29, 2024 - 15:11 UTC
Update
Please be advised that all payment processing has been run and/or will be completed at the next scheduled window.
Posted Mar 29, 2024 - 13:39 UTC
Monitoring
A fix is in place. However, we will continue to monitor for any other issues
Posted Mar 29, 2024 - 13:23 UTC
Identified
We have identified an issue that may cause payments to be delayed in processing. Our teams are actively working on resolving the issue.
Posted Mar 29, 2024 - 12:21 UTC