Specific Bank Partners: Transaction Posting Delayed

Incident Report for Treasury Prime

Resolved

Treasury Prime is currently seeing that payment processing is occurring as expected. Please direct any specific inquiries or issues to our support team at help@treasuryprime.com
Posted May 05, 2025 - 14:21 UTC

Update

Treasury Prime continues to monitor processing. The next update is expected for Monday, May 5th, as inbound payment activity resumes.
Posted May 02, 2025 - 23:51 UTC

Monitoring

Treasury Prime has seen some improvement in the receipt of transactions for processing, and execution of book transfers, but continues to monitor.
Posted May 02, 2025 - 20:49 UTC

Update

Treasury Prime continues to monitor performance and processing. Incoming items are being received and processed. We are seeing intermittent connectivity issues, which impacts book processing and can impact outgoing payments.
Posted May 02, 2025 - 18:15 UTC

Update

Treasury Prime has seen some incoming transactions being received and posted at both partner banks, but we continue to monitor the situation.
Posted May 02, 2025 - 17:09 UTC

Update

We continue to work with impacted parties, as the cause of the issue is tied to other data partners providing information to the Treasury Prime platform. We will provides updates as they are available.
Posted May 02, 2025 - 15:29 UTC

Investigating

Treasury Prime is currently investigating an issue which is impacting the posting of incoming items at two partner banks (Piermont Bank and Academy Bank). We are working with all parties to investigate and resolve.
Posted May 02, 2025 - 14:15 UTC
This incident affected: Bank Console.