Increased Timeouts During Account Closure

Incident Report for Treasury Prime

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 20, 2026 - 21:19 UTC

Investigating

Treasury Prime is currently investigating increased timeouts when patching an account to a "close_pending" status.
Posted Sep 20, 2026 - 20:13 UTC
This incident affects: API.