Card Authorization: Increased Timeouts

Incident Report for Treasury Prime

Resolved

No further incidents have been observed since the fix was deployed.
Posted Sep 09, 2026 - 19:08 UTC

Monitoring

A fix was deployed to the production environment and we are seeing a reduction in the issue. We continue to monitor.
Posted Sep 09, 2026 - 17:12 UTC

Identified

Treasury Prime is seeing an increase in timeouts on card authorizations; the issue is being triaged and we are working on a deployment to resolve the issue.
Posted Sep 09, 2026 - 16:01 UTC
This incident affected: API.