Application and Book Transfer Slowness

Incident Report for Treasury Prime

Resolved

Treasury Prime is now seeing the platform operating at expected levels. We will continue to monitor performance but do not expect further impact at this time.
Posted Apr 06, 2025 - 22:32 UTC

Update

Treasury Prime continues to see delays in book transfers and in application processing. The team is actively engaged in a remediation path.
Posted Apr 06, 2025 - 20:54 UTC

Monitoring

Treasury Prime has seen some improvement in book transfer processing but continues to monitor and evaluate.
Posted Apr 06, 2025 - 19:41 UTC

Identified

Treasury Prime has taken steps to improve performance but is continuing to monitor the platform.
Posted Apr 06, 2025 - 18:12 UTC

Investigating

Treasure Prime is seeing delay in completing book transfers and in applications moving to approved status. We are currently investigated.
Posted Apr 06, 2025 - 17:44 UTC
This incident affected: API.