Specific Bank Partner: OMB Bank File Connectivity

Incident Report for Treasury Prime

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 22:19 UTC

Monitoring

Treasury Prime has re-established connectivity and we are monitoring file exchanges.
Posted Jul 21, 2026 - 22:10 UTC

Update

Treasury Prime and OMB are currently working on a fix for this issue.
Posted Jul 21, 2026 - 21:10 UTC

Identified

Treasury Prime and the OMB team are currently engaged in resolving an issue related to file connectivity between the two parties. This is currently impacting our ability to share outgoing NACHA files. Both teams are working to resolve the issue.
Posted Jul 21, 2026 - 19:23 UTC
This incident affected: API.