Mastercard Digital Wallet Tokenization Failures

Incident Report for Treasury Prime

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 16:48 UTC

Monitoring

Our partner has reported a return to expected behavior for Mastercard digital wallet tokenization actions. We will monitor activity on our platform.
Posted Jul 29, 2026 - 14:26 UTC

Identified

Treasury Prime's card processing partner has identified an issue with Mastercard digital wallet tokenization where they are seeing failure to activate, suspend, resume, or remove tokens. They have escalated the issue with Mastercard and are actively working to resolve. Our programs may see failures when attempting to take action on digital wallet tokens as a result. We will update on status as more information is available.
Posted Jul 29, 2026 - 13:43 UTC
This incident affected: API.