Wire Processing Delays
Incident Report for Treasury Prime
Resolved
Treasury Prime resolved the issue and transmitted all wires to the originating banks for final execution.
Posted Jan 03, 2025 - 15:51 UTC
Investigating
Treasury Prime has identified an issue which is delaying a batch of wires set to transmit to the originating banks in the 9 am Eastern Time window. The team is currently working to resolve the issue, and expects the wires to be transmitted to the sending banks within the next 2 hours. Further updates will be posted as available.
Posted Jan 03, 2025 - 14:52 UTC
This incident affected: Bank Console.