OCT Credit Issue

Incident Report for Treasury Prime

Resolved

The impacting posting have been adjusted. If you have additional questions or concerns on any specific item please reach out to help@treasuryprime.com
Posted Oct 28, 2025 - 20:46 UTC

Monitoring

Treasury Prime is seeing posting executing as expected. We expect the posting adjustments to be completed within the next hour; the majority are complete at this time.
Posted Oct 28, 2025 - 19:18 UTC

Update

The fix to resolve the issue of duplication is complete. We continue to work on adjusting the posting.
Posted Oct 28, 2025 - 16:22 UTC

Identified

Treasury Prime is currently investigating an issue in which received OCT credit messages may have resulted in duplicate ledger postings. We are reverting the relevant deployment and are working to adjust postings.
Posted Oct 28, 2025 - 14:55 UTC
This incident affected: Bank Console.