Console - Account Details Page Error

Incident Report for Treasury Prime

Resolved

A fix was deployed and we are currently seeing the account details page behave as expected.
Posted Jan 21, 2026 - 22:55 UTC

Identified

Treasury Prime is aware that the account details page on the console is currently returning and error and we are actively working to resolve it.
Posted Jan 21, 2026 - 22:07 UTC
This incident affected: Bank Console.