Specific Bank Partner: Core Unavailable

Incident Report for Treasury Prime

Resolved

No further issues have been observed since the fix was deployed.
Posted Aug 19, 2025 - 20:04 UTC

Monitoring

Treasury Prime deployed a change; we are seeing successful communication and processing but continue to monitor.
Posted Aug 19, 2025 - 18:41 UTC

Update

Treasury Prime is working on deploying change which is expected to resolve the issue.
Posted Aug 19, 2025 - 17:41 UTC

Identified

Treasury Prime's connection with the Academy Bank core is impacted; book transfers, payment activities, and balance calls for on-core activities are unavailable.
Posted Aug 19, 2025 - 16:25 UTC

Investigating

Treasury Prime is currently investigating the communication between our platform and Academy Bank; core balances and other core related activities will be impacted.
Posted Aug 19, 2025 - 16:09 UTC
This incident affected: API.