Production Reduced Service Levels
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 19:03 UTC
Monitoring
A fix has been implemented by our partner and we are monitoring results.
Posted Sep 30, 2022 - 18:40 UTC
Investigating
Applications that are submitted may have delayed processing due to an incident with one of our partners.
Posted Sep 30, 2022 - 18:20 UTC
This incident affected: API.