Core API and SFTP Connection Issues - Specific Bank Partner: Bangor Savings

Incident Report for Treasury Prime

Resolved

No additional communication issues have been observed after the change was put into place.
Posted Sep 10, 2026 - 21:23 UTC

Identified

Our bank partner made a change to mitigate the issue and we are seeing improved communication in all channels. We continue to monitor processing.
Posted Sep 10, 2026 - 19:48 UTC

Investigating

Treasury Prime is currently triaging an issue with our connection to the core and SFTP process for a specific bank partner, Bangor Savings Bank. The communication issue will impact our ability to return core data and complete book transfers between core accounts. It will also impact payment flows dependent on book processing such as ACH origination, incoming ACH processing, and wire processing. We are currently investigating and will work to resolve as soon as possible.
Posted Sep 10, 2026 - 19:42 UTC
This incident affected: API.