All wire traffic continues to be monitored. Incoming wires at Bangor Savings Bank remain under review.
Posted Aug 19, 2025 - 16:03 UTC
Update
BANK SPECIFIC: International wires at First Bank have had a fix pushed, and the requests have been sent to the bank for processing.
Posted Jul 16, 2025 - 19:58 UTC
Update
Incoming wires for Academy Bank are seeing to be functioning as expected. Incoming wires at Bangor Savings Bank remain under review.
Posted Jul 16, 2025 - 19:57 UTC
Update
We are currently investigating issues handling incoming wire data for Academy Bank and Bangor Savings Bank. We are working with both parties to resolve the issue and push a fix.
Posted Jul 15, 2025 - 21:29 UTC
Update
BANK SPECIFIC: International wires from First Bank are not being processed at this time. Treasury Prime is working to deploy an update to resolve the issue and will resend the requests to bank for processing.
Posted Jul 14, 2025 - 19:35 UTC
Update
BANK SPECIFIC: Treasury Prime is currently investigating an issue sending international wires at First Bank
Posted Jul 14, 2025 - 17:21 UTC
Update
BANK SPECIFIC: Treasury Prime is currently investigating an issue with wire origination at OMB Bank. We will provide updates as that investigation continues.
Posted Jul 14, 2025 - 16:06 UTC
Update
BANK SPECIFIC: Inbound wires at Piermont Bank have successfully processed after a change. We will begin working through any items received to date.
Posted Jul 14, 2025 - 15:28 UTC
Update
BANK SPECIFIC: We are currently reviewing the incoming wire flow for Piermont Bank. Incoming wires may take longer to post that typical. Both teams are engaged in a resolution.
Posted Jul 14, 2025 - 13:43 UTC
Identified
On July 14, 2025, the Fedwire Funds Service will transition wire processing from the FAIM format to the new ISO 20022 format. While Treasury Prime has completed the tasks required to conform to the new format and have tested the change to the best of our abilities, there may be some unforeseen issues with wire processing as the change rolls out. If we encounter any issues, we will provide information on this incident.