Specific Bank Partner - MCB: Core Connectivity issue

Incident Report for Treasury Prime

Resolved

No additional connectivity issues have been observed since the change was made.
Posted May 08, 2026 - 13:06 UTC

Update

We are continuing to monitor for any further issues.
Posted May 07, 2026 - 22:38 UTC

Monitoring

We have implemented a change and are seeing successful core connectivity. We'll continue to monitor the platform.
Posted May 07, 2026 - 22:37 UTC

Investigating

Treasury Prime is seeing a loss of connectivity to the core for a specific partner bank, Merchant's Commerical. This will impact the availability of core balances. It will also impact payment processing for originated ACH items and book transfers. The team is working to identify and resolve the issue.
Posted May 07, 2026 - 13:17 UTC
This incident affected: API.