Pending Transactions

Incident Report for Treasury Prime

Resolved

Treasury Prime has resent webhooks where available and is not seeing any further impacts at this time. Please direct any additional questions or concerns to help@treasuryprime
Posted Aug 18, 2026 - 16:23 UTC

Update

Treasury Prime continues to monitor the platform. In addition to book transfers, webhooks may not have triggered consistently within other payment channels in that window.
Posted Aug 18, 2026 - 13:59 UTC

Monitoring

Pending book transfers have begun to resolve, and payment channels are processing as expected. The issue on our host was impacting items from 2026-08-18-04:40:00 to 2026-08-18-10:47:00 UTC. During this period is it possible that webhooks for book transfers did not trigger correctly. Please reach out to help@treasuryprime.com for questions regarding webhooks or books during this period.
Posted Aug 18, 2026 - 12:08 UTC

Identified

Treasury Prime identified an issue in one of our hosts and has resolved the issue. The team is currently reviewing impacts.
Posted Aug 18, 2026 - 11:03 UTC

Investigating

Treasury Prime is currently investigating an issue impacting book transfers remaining in a pending state. This may impact related payment processing such as ACH and wires. We are also investigating webhook transmission. We will provide updates as we investigate.
Posted Aug 18, 2026 - 10:35 UTC
This incident affected: API.