Production Reduced Service Levels
Incident Report for Treasury Prime
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 16:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2023 - 16:49 UTC
Identified
We have identified an issue with posting incoming ACH for customers on Piermont bank and are working on correcting this.
Posted Feb 03, 2023 - 15:44 UTC
This incident affected: API.